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Practice 15-1: Building a BI Publisher Report 
Based on an Answers Request 

Goals To create a BI Publisher report based on an Answers request and view its 
data in BI Publisher 

Scenario You create an Answers request with filters for dashboard prompts and use 
Oracle BI Publisher for Word to open the request and save it as a BI 
Publisher request. You then create and upload a template for use with the 
report and view the results. 

Time 30–40 minutes 

Instructions 

1. If necessary, start Oracle Business Intelligence Presentation Services and log in as 
Administrator. 

2. In Answers, create the following request using the SupplierSales subject area and 
save it as Sales by State and Region: 

 

3. Set filters for Is Prompted on both the Region and State columns. 

 

4. In Word, open the Sales by State and Region.rtf file in D:\labs. This is a 
simple rich text format file with a header, footer, and a title that will serve as the 
basis for a BI Publisher template for the Answers request you have created. 
Observe that the Oracle BI Publisher menu and toolbar is displayed in Word, 
indicating that Oracle BI Publisher Desktop is installed. Explore the options in the 
toolbar menus. 
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5. Select Oracle BI Publisher > Log On and log in as Administrator with password 
Administrator. If you are prompted for the report server URL, enter the URL in 
the following format: http://<Machine_Name>:9704/xmlpserver. 

 

6. The Open Template dialog box is displayed. By default, the template selection 
defaults to the BI Publisher workspace, displaying the BI Publisher folders and 
their respective reports and template layouts. Select Oracle BI from the 
Workspace drop-down list. Notice that your Presentation Catalog folders are 
displayed in the left-hand selection pane. 
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7. Select Users > Administrator > My Sales and, in the Reports list, double-click the 
Sales by State and Region BI Answers request. The Save As Oracle BI Publisher 
Report dialog box is displayed, allowing you to save the Answers request as a BI 
Publisher report in the BI Publisher folders. 

8. Select My Folders and click Save to save the report. When you save an Answers 
request as a BI Publisher Report, the XML data definitions are loaded into the 
RTF template file so that you can define the layout for the report data. 

9. Add a bar chart to the template. 
a. In the report template in Word, select <Insert  Bar Graph here>. 
b. In the BI Publisher toolbar, select Insert > Chart. 

 
c. In the Chart dialog box, drag Salesfacts.Dollars to the Values field. 
d. Drag Customers.Region to the Labels field. 
e. In their respective drop-down lists, select Bar Graph - Vertical as the Type, 

and select Comet as the Style. 
f. Enter Sales by Region as the Title. 
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g. Click Preview to see how the graph appears with your selections. 

h. Drag Periods.Year to the Series field and preview the graph. 

 
i. Click OK. 
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j. In the template, resize the chart so that it fits correctly in the table and verify 
your work: 

 

10. Add a pie chart to the template. 
a. In the report template in Word, select <Insert Pie Chart here>. 
b. In the BI Publisher toolbar, select Insert > Chart. 
c. In the Chart dialog box, drag Salesfacts.Units Ordered to the Values field. 
d. Drag Customers.Region to the Labels field. 
e. In their respective drop-down lists, select Pie Chart as the Type, and select 

Comet as the Style. 
f. Enter Units by Region as the Title. 
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g. Click Preview to see how the pie chart appears with your selections. 

 
h. Click OK. 
i. In the template, resize the chart so that it fits correctly in the table and verify 

your work: 

 
 

11. Add a table to the template. 
a.  In the report template, select <Insert Table here>. 
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b. In the BI Publisher toolbar, select Insert > Table Wizard to define a table 
format for the report data. 

c. Select Table and click Next. 
d. Click Next. 
e. Select Periods.Year, Customers.Region, Customers.State, and 

SalesFacts.Dollars in the left-hand list and add them to the right-hand list of 
fields to be included in the table, and then click Next. 

 
f. Select Periods.Year from the Group By drop-down list to group the data by 

year, and then click Next. 

 
g. Select Customers.Region from the Sort By drop-down list to sort first by 

region, and then select Customers.State from the Then By drop-down list to 
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set a secondary sort on the state. 

 
h. Click Next. 

 
 
 

i. Edit the labels of the fields Customers.Region, Customers.State, and 
Salesfacts.Dollars as Region, State, and Dollars. 

 
j. Click Finish and verify that your table appears in the template as follows. 

Notice the form fields with the gray background, which reference request data 
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in the template. 

 
k. Save the template. Note that you could also use Word formatting commands 

to specify the formatting of elements in the table, including cell formatting, 
justification, and font properties. 

l. You need to set a format to display the dollars in the correct format. Double-
click the _SalesFacts_._Dollars_ E form field in the Dollars column. 

m. In the BI Publisher Properties dialog box, click Word Properties. 
n. In the Text Form Field Options dialog box, select Number from the Type 

drop-down list. 
o. In the Default number field, enter 99,999,999.99, and in the Number format 

drop-down list, select the format with a leading $ symbol. 

 
p. Click OK. 
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q. Select Preview > PDF to preview your report and template in Adobe Acrobat. 

 

12. Upload the template. 
a. Select Oracle BI Publisher > Upload Template As. 
b. In the Upload as new dialog box, enter My Template as the template name. 
c. Click OK. 
d. Click OK when the message indicating that the template was uploaded 

successfully is displayed. 

 

13. View the BI Publisher report you created from an Answers request with the 
template you added to it. 
a. In Answers, select More Products > BI Publisher. 
b. On the Reports tabbed page of BI Publisher Enterprise, click the My Folders 

link to open the BI Publisher folder. 
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c. Click the View link below the Sales by State and Region BI Publisher report. 

 
d. Your report should appear in the template as follows: 
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Practice 15-2: Building a BI Publisher Report 
Using Oracle Business Intelligence Subject 
Areas 

Goals To create a BI Publisher report by building a logical query in BI Publisher’s 
Query Builder using a BI Server metadata subject area 

Scenario You create a new report, which uses a BI EE data source, building a logical 
query based on BI Server metadata using the BI Publisher Query Builder. 
You then upload an existing template and define a layout for the report so 
that you can view the results. 

Time 15–20 minutes 

Instructions 

1. Launch BI Publisher Enterprise and create a new report. 
a. In Answers, select More Products > BI Publisher. 
b. Click My Folders. 
c. Click Create a new report. 

 
d. Enter Units by State and Region in the Enter Report Name field and click 

Create. 
e. Click the Edit link below the Units by State and Region report. 
f. In the Edit view, click Data Model and click New to define the data source 

for this report. The Data Set page is displayed. 
g. Select SQL Query from the Type drop-down list. 
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h. Select Oracle BI EE from the Data Source drop-down list. 

 
i. Click Query Builder to create the SQL query. The Query Builder displays 

the SupplierSales subject areas from the BI Server metadata. 
j. Drag the Customers, Periods, and Sales Facts SupplierSales schema objects 

from the left-hand Schema selection pane onto the Model workspace on the 
right. 

k. Select the following columns for the query from objects (select the check 
boxes for each column): 
· Customers.Region 

· Customers.State 

· Periods.Year 

· SalesFacts.Units Shipped 
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l. Click the Conditions link and explore the grouping, sorting, and alias options 

you can use. Accept the defaults. 
m. Click the Results link to run the query and view the results. 

 
n. Click Save. 
o. In the Data Set page, note that the logical SQL query is displayed. This query 

uses the logical names for the metadata objects and is interpreted by the BI 
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Server, which provides the result set. 

 
p. Click Save to save the report’s data set. 

2. Create a layout and upload a template for the report. 
a. Click Layouts and click New to define a layout for the report. 
b. On the Layout page, enter Units by Region and State in the Name field. 
c. Click Layouts and, in the Manage Template Files area of the Create Layouts 

page, click Browse. 
d. In the Choose File dialog box, select the Units by State and Region.rtf 

file from D:\labs. This is a rich text format template that has been prepared for 
the BI Publisher report you have created. 

e. Click Upload to upload the template file. 

f. Select the Units by Region and State layout you created and verify that the 
Units by State and Region.rtf file appears in the Template drop-down 
list. 

g. Click Save. 



 RR I-TEC ,#209,Nilagiri Block,Adithya Enclave @8790998182,8801408841  

  

h. Click the View link to view the report in the template.  
i. Your report should appear in the template as follows: 

 

 



 RR I-TEC ,#209,Nilagiri Block,Adithya Enclave @8790998182,8801408841  

  

Practice 15-3: Publishing BI Publisher Reports 
in Interactive Dashboards 

Goals To add a BI Publisher report to a new Interactive Dashboard page 

Scenario You create a new dashboard page and then use the Dashboard Editor to 
add a dashboard prompt and a BI Publisher report to the page. 

Time 10–15 minutes 

Instructions 

1. Create a dashboard prompt for the region and state to filter the BI Publisher report 
results on the dashboard. 
a. In Answers, open Region and State Prompt. 
b. In the Set Variable column, select None from the drop-down list. 
c. Save the prompt in the My Sales folder as Region and State Prompt - No 

Variable. 

2. Click the Dashboards link. 

3. Select Page Options > Edit Dashboard to open the Dashboard Editor. 

4. Create a new Interactive Dashboard page. 
a. Click the Add Dashboard Page button . The Add Dashboard Page dialog 

box is displayed. 
b. Enter BI Publisher Page in the Page Name field. 
c. Click OK. 

5. Add the dashboard prompt to the section. 
a. Expand the My Sales folder. 
b. Drag the Region and State Prompt - No Variable prompt onto the default 

column. 
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c. Drag the BI Publisher Report object onto the section below the prompt. 

 
d. Click the Properties button in the BI Publisher Report 1 object. 
e. In the Folder Properties dialog box, click the Browse button. 
f. In the BI Publisher Report Properties dialog box, click Browse. 
g. In the Pick BI Publisher Report dialog box, navigate to the My Folders BI 

Publisher folder, select the Sales by State and Region report, and click OK. 
h. Click OK to close the BI Publisher Report Properties dialog box. 
i. Click the Save button in the upper-right corner. Your dashboard page should 

appear as follows: 
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j. Select Central and TX in the respective drop-down lists in the dashboard 
prompt and click Go. Your dashboard page should appear as follows: 


